Desarrolladores: su nueva aplicación en Play Store debe orientarse al nivel 26 de API

Cuando Google lanzó por primera vez el sistema operativo Android al mercado, la compañía tenía un enfoque de laissez-faire para los desarrolladores. Después de todo, la compañía necesitaba atraer a los desarrolladores para que trajeran sus aplicaciones y servicios a la nueva plataforma. Sin embargo, muchas de estas primeras decisiones se volvieron a poner en práctica más tarde, ya que resultaron en una mala experiencia del usuario, lo que permite que las aplicaciones hagan lo que quieran, lo que hace que las aplicaciones hagan lo que quieran. Con las versiones más recientes de Android, las aplicaciones no pueden enviar notificaciones de spam, usar servicios en segundo plano sin notificar explícitamente al usuario, acceder a permisos confidenciales sin un diálogo que otorgue permiso y mucho más. Sin embargo, Google facilitó que las aplicaciones eludieran estas restricciones fáciles de usar al permitir que las aplicaciones continúen dirigidas a versiones anteriores de SDK. En diciembre pasado, Google anunció que todas las nuevas aplicaciones enviadas a Google Play Store deben apuntar al menos al nivel 26 de API (Android 8.0 Oreo). Finalmente es agosto, lo que significa que si está trabajando en una nueva aplicación y planea enviarla a Play Store, ¡es mejor que apunte a Android 8.0 Oreo!

Agosto de 2018: todas las aplicaciones nuevas deben alcanzar el nivel 26 de API

Google le ha dado mucho tiempo para realizar ajustes en su aplicación para cumplir con los nuevos requisitos. Actualizar su aplicación a un nuevo nivel de API será para su beneficio en el futuro, así como para sus usuarios. Sus usuarios disfrutarán el hecho de que su aplicación se comporta de manera consistente con otras aplicaciones en su dispositivo, mientras que se ahorrará un poco de dolor de cabeza ya que el próximo año Google incrementará el requisito de targetSdkVersion. Si se retrasó y esperó para actualizar su aplicación para cumplir con este requisito, tenga en cuenta que después de un año después del lanzamiento de Android P, el nuevo requisito targetSdkVersion será API nivel 28 o superior.

Google no está tratando de castigarte obligándote a hacer un esfuerzo para mantener actualizada tu aplicación. La compañía solo quiere que ayudes a mantener seguros los dispositivos de tus usuarios asegurándote de que utilizas todas las últimas API y solicitudes de permisos. Si le preocupa que los usuarios con dispositivos más antiguos no puedan disfrutar de su aplicación, se alegrará de saber que no hay un piso para la versión mínima de SDK que puede configurar. En cuanto a los desarrolladores que ya mantienen una o más aplicaciones en Play Store, su aplicación debe orientarse al nivel 26 de API para noviembre de 2018 si desea que se le permita enviar actualizaciones a su aplicación en Play Store.