Google no agregará soporte para aptX en el Nexus 5X y Nexus 6P

Con Android O, Google agregó soporte para más códecs de audio Bluetooth como LDAC de Sony, así como aptX y aptX HD de Qualcomm para permitir la transmisión de audio bluetooth de alta calidad en dispositivos compatibles.

Si tiene una Vista previa de desarrollador de Android O, puede encontrar una opción para elegir entre varios códecs de audio Bluetooth en Opciones de desarrollador. Sin embargo, tenga en cuenta que estos códecs no funcionarán a menos que se instalen las bibliotecas de codificadores adecuadas. Caso en cuestión: parece que Nexus 5X y Nexus 6P no podrán aprovechar aptX después de todo.

En caso de que no lo sepa, aptX es un códec Bluetooth patentado propiedad de Qualcomm que permite a los dispositivos compatibles transmitir audio sin pérdidas y de baja latencia a dispositivos compatibles con Bluetooth. Aunque los dos teléfonos Pixel son compatibles con el códec, falta el códec de audio Bluetooth en las Opciones de desarrollador en los dos dispositivos Nexus. El problema salió a la luz por primera vez cuando un usuario de Nexus 6P presentó un informe de error en la página del Rastreador de problemas de Google mencionando que no pudo hacer que el códec de audio funcionara en su dispositivo, a lo que un desarrollador de Google respondió con el siguiente mensaje:

Estado: no se solucionará (comportamiento previsto)

Desafortunadamente, el soporte para aptX y aptX HD no son compatibles con Nexus 6p y Nexus 5X, solo en dispositivos más nuevos.

Así que ahí lo tiene: tanto el Nexus 5X como el Nexus 6P no son compatibles oficialmente con aptX y aptX HD, y Google no tiene planes de agregar soporte para ellos. Podría ser que Google esté buscando evitar posibles tarifas de licencia que tendría que pagar a Qualcomm si agregara soporte para sus códecs propietarios en Nexus 5X y Nexus 6P, sin embargo, nunca sabremos la razón exacta a menos que Google proporcione oficialmente una declaración sobre este asunto.

Sin embargo, extraoficialmente, es posible que funcione en estos dispositivos. De hecho, ya hay un módulo Magisk disponible para el Nexus 6P que permite la compatibilidad con aptX. Dirígete al hilo oficial para obtener más detalles sobre cómo habilitar aptX en el Nexus 6P.


Fuente: Google Issue Tracker Vía: Android Police